Tuesday, September 25, 2012

Connections 1.0 Mail - requirements

As a followup to my last post regarding what to download when you are going to install IBM Connections 4, I thought a system requirements for blogpost for Connections 1.0 Mail is in order aswell.

Connections 1.0 mail was released last week, and the Connections team has done a good job with releasing the documentation at the same time.

Here´s the download link for IC4.0 Mail package:
https://greenhouse.lotus.com/plugins/plugincatalog.nsf/assetDetails.xsp?action=editDocument&documentId=31651AAAE1F4913685257A5F00548896

Here´s how you install the Mail package:
http://www-10.lotus.com/ldd/lcwiki.nsf/dx/Installing_IBM_Connections_Mail_icm1


Here´s the link for the Prereqs:
http://www-01.ibm.com/support/docview.wss?uid=swg27036069

Clicking on "Windows" for instance, shows you what you need regarding iFixes and fixpacks.

On the Connections side, there are 3 iFixes needed.



  • IBM Connections 4.0 interim fix LO71325
  • IBM Connections 4.0 interim fix LO71327
  • IBM Connections 4.0 interim fix LO71328

  • Two of which is also listed as the prereq for IC4.0, but the last one is new. So be sure to download the LO71328 aswell if you are planning to use IBM Connections Mail.

    If you are using Domino Mail, you also need to upgrade your domino server.
    The prereq is:

    • IBM Lotus Domino 8.5.3 Fix Pack 2
    • iNotes 8.5.3 Fix Pack 2 Interim Fix 1 for Connections Mail 1.0   
    So, you need 2 packages installed. The FP2 for domino 8.5.3 and the iNotes Interim Fix1 on top of that.

    When you go into Fix Central, you will not find a IFR1 with the name "iNotes 8.5.3 Fix Pack 2 Interim Fix 1 for Connections Mail 1.0", UNLESS you select "iNotes" as the product.
    Filename is:

    iNotes_853FP2IF1_W32_IBMConnectionsMail




    Thanks to @eborse for pointing this out!

    If you are using Exchange as the mail system, then you need to enable SPNEGO/Kerberos in order for the SSO to work.
    When using Domino as the mail system, LTPA is the way to go.



    Wednesday, September 12, 2012

    IBM Connections 4 - Download Packages - Overview

    In the "jungle" of downloadable choices regarding Connections 4, I´ve created this list for the most "common" installation that I usually set up for customers.

    I have not included any System Z versions here, but Windows, Linux and AIX is here

    UPDATE: Remember that the prereq for DB2 is Fixpack 5, and also the prereq for WAS is Fickpack 21. So remember to download those aswell.
    And FP21 for the HTTP server, the WASSDK and the WASPLUGIN is also something that you need.



    UPDATE: Also, there are 5 WAS fixes for FP21 you need to add:
    PM53930, PM56596, PM60895, PM51981, PM65486.
    1. PM53930
    2. PM56596
    3. PM60895
    4. PM51981
    5. PM65486

    And Connections 4 itself has two fixes that also is required. LO71325, LO71327 and LO71328:
    Download all three fixes from fixcentral here


    UPDATE: IBM Connections 4.0 CR1 includes all three fixes mentioned in this document. CR1 can be applied on its own, as it contains the changes included in these fixes. CR1 can also be applied on environments that already had these fixes applied.
    So instead of installing these 3 fixes, just download CR1 here:
    http://www-01.ibm.com/support/docview.wss?uid=swg21612692

    Common stuff:
    • IBM Connections V4.0 Quick Start Guide for AIX, Windows, Linux Multilingual (CIA3CML)
    • IBM DB2 9.7, Enterprise Server Edition - Restricted Use - QuickStart Guide and Activation Multiplatform Multilingual (CZ381ML)

    Windows only:
    • IBM Connections V4.0 for Windows Multilingual (CIA3DML)
    • IBM Connections V4.0 Wizard for Windows Multilingual (CIA3GML)

    • IBM DB2 Enterprise Server Edition 9.7 for Windows® on 32-bit AMD and Intel systems (x86) Multilingual (CZ19HML)
    • IBM DB2 Enterprise Server Edition 9.7 for Windows® on AMD64 and Intel® EM64T systems (x64) Multilingual (CZ19IML)

    • IBM Tivoli Directory Integrator Identity Edition V7.1 for Windows x86-64, Multilingual (CZ9MKML)
    • IBM Tivoli Directory Integrator Identity Edition V7.1 for Windows x86, Multilingual (CZ9MJML)

    • IBM WebSphere Application Server Network Deployment V7.0 for Windows on x86-32 bit, Multilingual (C1G2GML)
    • IBM WebSphere Application Server Network Deployment V7.0 for Windows x86-64 bit, Multilingual (C1G2JML)

    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (1 of 2) for Windows on AMD 64-bit (Application Client, IBM HTTP Server, Web Server Plug-ins and Update Installer) Multilingual (C1G2KML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (2 of 2) for Windows on AMD 64-bit (Migration Tool) Multilingual (C1G2LML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (1 of 2) for Windows x86-32 bit (Application Client, IBM HTTP Server, Web Server Plug-ins and Update Installer) Multilingual (C1G2HML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (2 of 2) for Windows on x86-32 bit (Migration Tool) Multilingual (C1G2IML)


    Common Linux&AIX:
    • IBM Connections V4.0 Wizard for Linux, AIX Multilingual (CIA3HML)
    • IBM Connections V4.0 for Linux, AIX Multilingual (CIA3EML)

    Linux only:

    • IBM DB2 Enterprise Server Edition 9.7 for Linux® on AMD64 and Intel® EM64T systems (x64) English (CZ19NEN)

    • IBM Tivoli Directory Integrator Identity Edition V7.1 for Linux x86-64, Multilingual (CZ9MNML)
    • IBM Tivoli Directory Integrator Identity Edition V7.1 for Linux x86, Multilingual (CZ9MMML)

    • IBM WebSphere Application Server Network Deployment V7.0 for Linux on x86-32 bit, Multilingual (C1G32ML)
    • IBM WebSphere Application Server Network Deployment V7.0 for Linux on x86-64 bit, Multilingual (C1G35ML)

    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (1 of 2) for Linux on x86-32 bit (Application Client, IBM HTTP Server, Web Server Plug-ins and Update Installer) Multilingual (C1G33ML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (2 of 2) for Linux on x86-32 bit (Migration Tool) Multilingual (C1G34ML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (1 of 2) for Linux on x86-64 bit (Application Client, IBM HTTP Server, Web Server Plug-ins and Update Installer) Multilingual (C1G36ML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (2 of 2) for Linux on x86-64 bit (Migration Tool) Multilingual (C1G37ML)


    AIX only:
    • IBM DB2 Enterprise Server Edition 9.7 for AIX English (CZ19JEN)

    • IBM Tivoli Directory Integrator Identity Edition V7.1 for AIX, Multilingual (CZ9MLML)

    • IBM WebSphere Application Server Network Deployment V7.0 for AIX on PowerPC 64-bit, Multilingual (C1G2QML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (1 of 2) for AIX on PowerPC 64-bit (IBM HTTP Server, Web Server Plug-ins and Update Installer) Multilingual (C1G2RML)
    • IBM WebSphere Application Server Network Deployment V7.0 Supplements (2 of 2) for AIX on PowerPC 64-bit (Migration Tool) Multilingual (C1G2SML)