Thursday, February 7, 2013

IBM Connections 4 CR2 - updating using the Silent Updater

I love using the silentinstaller to upgrade Connections. But in Connections 4 CR2, the fixes for all of the apps has the same LO number; LO72170. (Pluss, the Common app has LO73212 on top of that)

How to use the Silent Updater is described here:
http://www-10.lotus.com/ldd/lcwiki.nsf/dx/Installing_interim_fixes_ic40

Following the description on how to use the silent updater means that the command:

updateSilent.bat -fix -installDir c:\ibm\connections -fixDir C:\IBM_SW\cr2 -install -fixes LO72170 LO73212 -wasUserId xxxxxx -wasPassword xxxxxx -featureCustomizationBackedUp yes -homepageDBSchemaUpdatesHaveBeenCompleted yes
Does not work....

You will first and foremost get an error complaining about that the LO73212 requires LO72170 to be installed first as a prereq.
 (Text version:
Install prerequisite errors:
[0]: A fix prerequisite relationship was not satisfied.
[1]: The fix LO73212 has the fix LO72170-IC4000-CR02-Common as a prerequisite, but that fix is not currently installed, and is not selected for installation.)

Then, of course, I tried omitting the LO73212 with this command:

updateSilent.bat -fix -installDir c:\ibm\connections -fixDir C:\IBM_SW\cr2 -install -fixes LO72170 -wasUserId xxxxxx -wasPassword xxxxxx -featureCustomizationBackedUp yes  -homepageDBSchemaUpdatesHaveBeenCompleted yes

But then I got this error:
Text version:
Fixes were specified which do not exist:
   LO72170

So.... how do I specify that I would like to install every Applications CR2 when only having a single LO number to work from?

I then found the solution:
When you run the first command, as described above, to install the LO72170 and the LO73212, you will get a listing of the efix ID´s in the Command Prompt window:

I then copied out the efix ID´s and inserted them into the updateSilent.bat command:
updateSilent.bat -fix -installDir c:\ibm\connections -fixDir C:\IBM_SW\cr2 -install -fixes LO72170-IC4000-CR02-Common LO72170-IC4000-CR02-Activities LO72170-IC4000-CR02-Blogs LO72170-IC4000-CR02-Bookmarks LO72170-IC4000-CR02-Communities LO72170-IC4000-CR02-Container LO72170-IC4000-CR02-Files LO72170-IC4000-CR02-Forums LO72170-IC4000-CR02-Homepage LO72170-IC4000-CR02-Metrics LO72170-IC4000-CR02-Mobile LO72170-IC4000-CR02-MobileAdmin LO72170-IC4000-CR02-Moderation LO72170-IC4000-CR02-News LO72170-IC4000-CR02-Profiles LO72170-IC4000-CR02-Search LO72170-IC4000-CR02-Wikis -wasUserId xxxxxx -wasPassword xxxxxx -featureCustomizationBackedUp yes -homepageDBSchemaUpdatesHaveBeenCompleted yes
And then the CR2 update worked!
As you can see, I omitted the LO73212 in the command. After this command was done, I then ran the LO73212 command:
updateSilent.bat -fix -installDir c:\ibm\connections -fixDir C:\IBM_SW\cr2 -install -fixes LO73212 -wasUserId xxxxxx -wasPassword xxxxxx -featureCustomizationBackedUp yes -homepageDBSchemaUpdatesHaveBeenCompleted yes

And there you have it. CR2 is installed!

3 comments:

Christoph said...

Hi,

i had this problem too, but when you check the silentupdate.sh Script, you find this:

# The '-fix' option specifies an eFix update.
# The '-fixpack' option specifies a FixPack update.

So when you call the script with -fixpack you mustn't add all efix ids.

Regards
Chris

Robert Farstad said...

Ahaaaaa. Thanks Chris!

jagan said...

Hi,

Thanks - this saved my Day.

:)