Thursday, November 7, 2013

IBM Sametime 9 - Media Manager components required startup order

EDIT:
I think this is fixed in the latest Media Manager Fix pack. HotFix1.

Today I discovered that there might be a specific startup order for the Media Manager servers for the Sametime 9 environment.

I had no Video conferencing option after a reboot, and the SP+CF servers SystemOut.log told me that a connection to the VMGR server was "denied".

So, I then shut down the SP+CF server, shut down the VMGR and of course the SolidDB as well. Started the SolidDB and then the VMGR.
Waited for the VMGR to finish starting, then I fired up the SP+CF server.

Bingo, Video Conferencing option was back!

I mentioned this to an IBM L2 support guy, and he will verify if this is actually so. He has a ST9 environment himself where he can test this.

Can anyone else verify?

There should be a "if no connection to vmgr, wait and retry" function on the SP+CF server. If there was, this would no be an issue.

8 comments:

Anonymous said...

Thanks for ur information. it help after 3 days of my failure work to start VMGR server and Communicate with media server and SSC. Sametime 9.0 Document (WIKI) did not say anything about solidDB. Why?

TuhinBlack said...

Thanks for ur BIG information. last 3 days i was trying to solve the same error on my VMGR to Media Server and SSC communication but fail. now it worked after solidDB. Why Sametime WIKI don't say anything about this solidDB?

And Meeting Server on Linux, do you know anything about Sametime Video capture and Sametime Video Render? Video Capture is working fine but Renderer is not doing anything. checking log and found a warning saying "Sametime Video Renderer..Windows Only" !!!

Robert Farstad said...

Hi there. It´s nice to see that it´s other that have the same issue out there.

Regarding the SolidDB: I think IBM realized that the SolidDB restart documentation was in fact missing, and created a quick technote on it instead. They will probably update the wiki later on.

Regarding the Meeting server. I have the same rendering issue. And I have 2 environments, one on Linux and one on Windows.
It works to create a Quicktime recording but not a Windows Media recording.

And I´ve also spoken with IBM L2 support on this, and they see the same issue on their test installation as well.

So what you and I should do is create a PMR on this. Please let me know the PMR number, so that I can reference to it when I create my PMR on it as well.

Robert Farstad said...

Rendering is now solved. It´s "Windows only" that is the solution. So rendering is only supported on the Windows platform, where you have to add the "Desktop experience" on the windows server where the meeting server (rendering server) is running.

Take a look at Frank Altenburgs ST9 Zero To Hero guide on page 120 for the solution.

TuhinBlack said...

Thank Robert Farstad. I have already transfer Capture and Render server to windows. So now there is two meeting server, one is Base meeting with Document Capture install on Linux AND another is for Capture and Render install on windows 2008R2 including "Desktop Experience. Base meeting with Document Conversion along with Multi A/V (VMGR+MCU) working fine. But Stuck on Recording and capture.
My Base meeting config is, (my ports is 80,443)
Recording.api.remote.url http://stcapture.somedomain.com
Recording.capture.iscaptureserver false
Recording.capture.serveraddress http://stcapture.somedomain.com
Recording.render.isrenderserver false

My stcapture config is, (my ports is 80,443)
Recording.capture.meetingserveraddress http://stmeeting.somedomain.com
Recording.capture.serveraddress http://stcapture.somedomain.com
Recording.capture.iscaptureserver true
Recording.render.serveraddress http://stcapture.somedomain.com
Recording.render.isrenderserver true

Click on recording and select WMV/MOV both give me an error, “An error has occurred and the recording did not start. Try stating the record again”. Why? Still working on it.

Robert Farstad said...

Is there anything useful in the systemout logs for your meeting/rendering servers? And the stcapture folders. Does the user that starts the servers have access to them?

TuhinBlack said...

Do i need to Share "stcapture" and "strender" on network share for sametime users? some files is created on those folder but very small size, 6 to 7 kb only inside a sub-folder.

Robert Farstad said...

Sorry for the late reply.

No, I don´t think you have to put in on a shared network drive. As I understand it, you have one meeting server that takes care of the catpure and render. This is the server where the stcapture and strender folder needs to reside on.
Make sure that the user that starts the Websphere Windows service has write access to the folders.