Wednesday, September 28, 2016

Docs 2.0 CR1 iFix 001 - Conversion app will not update.

Has anyone had issues with upgrading Docs CR1 to the CR1 iFix1?
This is the log error:

INFO This iFix is not for your current DocsConversion version. Please double check.

DocsApp and ViewerApp is updated fine, but not the conversion App.
I have gone through the file, and managed to figure out that the script looks for the file “conversion-config.json” in the IBMDocs-Config folder on the DMGR server. (D:\IBM\WebSphere\AppServer\profiles\Dmgr01\config\cells\appsrv1Cell01\IBMDocs-config)

It looks for the string “ifix_version” with a value >=6
This is a value that does not exist in the conversion-config.json file.

So I manually edited the conversion-config.json file on the dmgr server, to include the “ifix_version” part. I set the value to 6:
It´s located under the "build-info" section and the format is:
    "ifix_version": 7, 

After I did this, the applypatch procedure worked fine, and the conversion app was upgraded sucessfully.

I now see that the upgrade process has set the value to “7”.

"build-info": {    "build_version": "",     "build_description": "IBM Connections Docs 2.0.0",     "ifix_version": 7,     "product_name": "IBM Connections Docs",     "build_timestamp": "20160824-1613"  },

The upgrade history of the server is: Docs 2.0. Then CR1 and then CR1 iFix 001.

I did not install Docs 2.0 ifix 001, 002, 003, 004, 005 first, since the CR1 package should include all of those.

Is this a bug in the upgrade process? Should the "ifix_version" string have been inserted into the conversion-config.json file in one of the previous Docs 2.0 iFix´es? 001? 002? 003?....
I don´t know. But this worked as a nice workaround.

No comments: